Lumia stuck on getting things ready?

I waited with baited breath for a new Lumia 950, my first for a while and the first real device for eurotechtalk. It not only meant a new device for me to play with, but signalled that we were being taken seriously and things were looking good.

Microsoft had offered to send me a Lumia 950 XL — not just the handset but the whole set up complete with display dock, keyboard and mouse. The whole box arrived the very next day, with the Lumia 950 in packaging that oozed class and quality, I couldn’t wait to pop my sim in and get it started. Unfortunately that is where the issued started — if you get the issues with your Lumia 950 here is how to fix it.

Getting things sorted

The first boot takes a while on any phone, but I waited and watched the little message “getting things ready” on the screen waiting for the first signs of a boot. However that is all that remained on the screen for a long long time. It vibrated every so often and needed turning on again, only to be greeted by the same message — what exactly could it still be getting ready?

After an hour I began to panic that the phone was faulty, Twitter reassured me this was normal but it didn’t feel like an experience any user should have to go through. After another 20 mins I resorted to Googling the issue, found the fix and got it going within a further few mins. Here is what you need to do if you get the same.

Lumia 950 Hard Reset

You need to perform a ‘hard rest’ by doing the following.

  • Remove and re-insert the battery.
  • Hold down the power button and the volume down button.
  • When you feel a vibrate release the power button but continue to hold the volume down until you see an exclamation mark on the screen.
  • Then press the following key sequence. Volume up, Volume down, Power button and then volume down.
  • The phone will now wipe itself and boot as normal

I have no idea why it would need this, and anyone that spent money on the phone will not enjoy this experience at all. I am not alone either there are various forum threads asking for help and some people stuck for hours. Including this one from Windows Central where I found the solution to my problems.

Site Footer